<center id="qkqgy"><optgroup id="qkqgy"></optgroup></center>
  • <menu id="qkqgy"></menu>
    <nav id="qkqgy"></nav>
    <xmp id="qkqgy"><nav id="qkqgy"></nav>
  • <xmp id="qkqgy"><menu id="qkqgy"></menu>
    <menu id="qkqgy"><menu id="qkqgy"></menu></menu>
    <tt id="qkqgy"><tt id="qkqgy"></tt></tt>

  • <>VLAN 在交換機中工作

    分割廣播域
    物理分割--------子網掩碼劃分
    邏輯分割---------VLAN劃分
    VLAN的優勢
    控制廣播
    增強網絡安全性
    簡化網絡管理
    VLAN的種類
    靜態VLAN:基于端口劃分靜態VLAN
    動態VLAN:基于MAC地址劃分動態VLAN
    VLAN的ID范圍
    0~4095共4096個
    其中0和4095兩個為系統保留,不可用。可用范圍為1~4094,其中1為系統默認純在的VLANid。

    <>配置 VLAN(以ensp為例)

    sys---------進入系統視圖模式
    dis vlan---------查看當前vlan配置

    vlan 10 ------創建vlan
    quit----------退出回到視圖模式
    vlan batch <id數> <id數> <id數> ------------批量創建vlan

    刪除vlan
    undo vlan 10

    交換機鏈路類型 access trunk hybrid(華為/H3C默認的鏈路類型)
    access,常配置在交換機連接計算機/路由器的端口,用于將進入交換機的數據打上到某個vlan標識,或者將從交換機發出的數據脫掉某個vlan標識
    trunk,通常配置在交換機與交換機連接的端口,用于識別哪些vlan標識被允許交換機與交換機之間的vlan通信

    <>access接入鏈路

    將端口加入VLAN,Access口只能屬于1個VLAN,一般用于連接計算機端口
    [Huawei] int e0/0/1(進入接口模式)
    [Huawei-Ethernet0/0/1] port link-type access(定義二層端口為access模式)
    [Huawei-Ethernet0/0/1] port default vlan 10(將端口加入到vlan10中)
    [Huawei-Ethernet0/0/1] undo shutdown

    將端口從vlan刪除
    [Huawei-Ethernet0/0/1] undo port default vlan <id數>
    [Huawei-Ethernet0/0/1] port link-type hybrid(將端口類型恢復成默認的hybrid模式

    查看當前端口模式、狀態
    [Huawei-Ethernet0/0/1] dis this

    同時將多個端口加入VLAN
    [Huawei] port-group 1 (新增組1)
    [Huawei-port-group-l] group-member Ethernet 0/0/1 to Ethernet 0/0/20
    (組1的成員是e0/0/1到e0/0/20)
    [Huawei-port-group-1] port link-type access
    [Huawei-port-group-1] port default vlan 30

    端口恢復默認配置,注意,執行完命令后,接口會被shutdown
    [Huawei] clear configuration interface e0/0/1

    查看指定VLAN信息
    [Huawei] dis vlan 10

    接入鏈路access 交換機連接計算機/路由器的端口,用于將進去交換機的數據加入到某個vlan中,或者將從交換機發出的數據脫掉vlan標識
    中繼鏈路trunk 交換機連接交換機的端口,用于允許那些vlan可以在交換機與交換機之間的vlan通信

    <>trunk中繼鏈路

    以太網上實現中繼,有兩種封裝類型
    ISL(Cisco私有)
    IEEE802.1q
    IEEE802.1q工作原理

    IEEE802.1q幀格式

    IEEE 802.1q的標識(4字節):
    2字節標識協議標識符(TPID)包含一個 0x8100 的固定值,這個特定的 TPID 值指明了該帶有 IEEE 802.1q 的標識信息
    2字節標識控制信息 (TCI) 包含了下面的3個元素:
    -3位的用戶優先級(Priority):IEEE 802.1q 不使用該字段。
    -1位的規范格式標識符(CFI):CFI 常用于以太網和令牌環網。在以太網中,CFI 的值通常設置為 0。
    -12位 VLAN 標識符(VLAN ID):該字段唯一標識了幀所屬的 VLAN。VLAN ID可以唯一地標識 4096 個 LAN,但 LAN 0 和
    LAN 4095 是被保留的。

    <>如何配置trunk接口(要先設添加vlan端口才能繼續)

    [Huawei]vlan batch 10 20 30
    [Huawei]int e0/0/0
    [Huawei-Ethernet0/0/0]port link-type trunk(定義二層端口為trunk模式)
    [Huawei-Ethernet0/0/0]port trunk allow-pass vlan 10 20 30(配置Trunk端口允許通過的vlan)
    [Huawei-Ethernet0/0/0lundo shutdown

    [Huawei-Ethernet0/0/0]undo port trunk allow-pass vlan
    10(禁止Trunk傳送某個VLAN的數據,刪除這個VLAN)
    建立如下實驗環境

    拓展port trunk allow-pass vlan 10 20 30此命令也可使用port trunk allow-pass vlan
    all,代表允許通過所有的vlan,此時要注意刪除時,undo port trunk allow-pass vlan all會將系統默認的vlan1也刪除
    不許通過,在此時要還原vlan1即port trunk allow-pass vlan 1 。
    添加多個vlan則port trunk allow-pass vlan 10 to 30 代表添加從10到30的所有vlan

    此處舉例為二層交換機,注意交換機上面不能配置IP地址,因為在數據鏈路層。
    圖例展示各個節點該配那些東西

    技術
    下載桌面版
    GitHub
    百度網盤(提取碼:draw)
    Gitee
    云服務器優惠
    阿里云優惠券
    騰訊云優惠券
    華為云優惠券
    站點信息
    問題反饋
    郵箱:ixiaoyang8@qq.com
    QQ群:766591547
    關注微信
    巨胸美乳无码人妻视频